in Office 365 API

[FIXED] Fix for Unable to find version ‘1.0.22’ of package ‘Microsoft.Azure.ActiveDirectory.GraphClient’

Update 1/12/205: This issue is now fixed. The missing package Microsoft.Azure.ActiveDirectory.GraphClient 1.0.22 was uploaded to the NuGet.org and it will be restored when required.

Office 365 API Tools not only allows you to register and configure an Azure AD app for your application to consume Office 365 APIs, the tool also adds the respective NuGet packages to interact with the services configured.

The Problem

As mentioned earlier in my blog post – Getting started with Office 365 Client LibrariesAzure Active Directory Graph Client Library will be added if your app wants to interact with Active Directory Graph API.

The tools adds the following version of the library that was shipped along with the tools:

  • Azure Active Directory Graph Client Library 1.0.22

aad-graph-1.0.22

Unfortunately, this package version 1.0.22 was not uploaded to the NuGet repository and hence when you try to restore the NuGet packages in your projects, Visual Studio fails with the following message:

Error 2 NuGet Package restore failed for project MVC_SSO: Unable to find version '1.0.22' of package 'Microsoft.Azure.ActiveDirectory.GraphClient'.

The Fix

While the tools will fix this in the next release (by installing the right version of the Azure AD Graph client NuGet package), the fix for now is to update the NuGet package to the current version 2.0.2.

To do this, just open the NuGet Package Manager and click on Updates.

You should see the 2.0.2 available as an update for the Azure AD Graph client library NuGet package.

aad-graph-2.0.2

This will fix the issue.

Andrew Connell also has blogged about this in his blog. I would highly recommend reading the same.

Feel free to leave a comment below if you have any questions!

If you have a product/feature request, make sure you post your idea here!

Happy Coding!

 

Write a Comment

Comment

Time limit is exhausted. Please reload the CAPTCHA.